Back
Maintenance

Routine Database Maintenance

Completed 11 Sep at 09:00am BST.

givengain.com
Completed

Maintenance completed

Posted 11 Sep at 09:00am BST.
Started

We’re continuously working to ensure a better experience for all of our valued users like you. 
Our tech team will be conducting routine website maintenance on 11 September.

The platform should be available again after a 2-hour offline period.
You can check here for updates or reach out to your dedicated regional team.

UK/EU: annie.blanchard@givengain.com
US: bryan.lively@givengain.com  
SA: jannie.smith@givengain.com     

Posted 11 Sep at 07:00am BST.