Back
Maintenance

Routine Database Maintenance

Completed 12 Mar at 09:00am GMT.

givengain.com
Completed

Maintenance completed

Posted 12 Mar at 09:00am GMT.
Started

We’re continually improving the security and speed of our platform and we’ll be conducting a scheduled technical systems upgrade. We expect this process to take up to 2 hours to complete.

Posted 12 Mar at 08:00am GMT.